解决Cent OS Yum 命令安装软件时出现fwupdate-efi和grub2-common冲突

笔者在安装了Cent OS 7.5后,手动安装了桌面系统。在使用Yum命令时,出现了Transaction check error:file /boot/efi/EFI/redhat from install of fwupdate-efi-12-5.el7.x86_64 conflicts with file from package grub2-common-1:2.02-0.65.el7_4.2.noarch的错误信息,现分享解决方案如下——

该问题源于文件的版本冲突:

grub2-common包的冲突,所以要将该包使用yum update grub2-commonn命令进行更新。


解决方案:

#yum update grub2-common
#yum install fwupdate-efi

即可解决。



解决方案原文:

Restating the issue:

This will not affect RHEL 7.6 fresh installs as that will come with the updated grub2-common. fwupdate-efi conflicts with all versions of grub2-common below grub2-common-2.02-0.76.el7.noarch currently. 


 # rpm -q grub2-common
    grub2-common-2.02-0.65.el7_4.2.noarch

 # yum groupinstall "Server with GUI"
    Transaction check error:
      file /boot/efi/EFI/redhat from install of fwupdate-efi-12-5.el7.x86_64 conflicts with file from package grub2-common-1:2.02-0.65.el7_4.2.noarch

 # yum install fwupdate-efi
    Transaction check error:
      file /boot/efi/EFI/redhat from install of fwupdate-efi-12-5.el7.x86_64 conflicts with file from package grub2-common-1:2.02-0.65.el7_4.2.noarch


*** Updating grub2-common will workaround this issue allowing customers to install Server with GUI or fwupdate-efi as required ***

 # yum update grub2-common
 # rpm -q grub2-common
   grub2-common-2.02-0.76.el7.noarch
 # yum install fwupdate-efi

原文链接


解决了你的问题?点个赞吧~(~ ̄▽ ̄)~

3544

文章分类:Linux

所属标签: linux cent os 服务器 问题解决


评论:

假若他日相逢:

  感谢楼下《浮云》同学的指正,目前已经修改过来啦~

浮云:

  解决方案里应该是yum update grub2-common吧,你后面多了个n……

啊~评论区就像肚皮一样空荡荡的。。。快来留下点啥充充饥